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Overview OSG Seminar Manager for
Joomla 3
Here you will find a detailed description of the functions, the manuals for (OSG) Seminar
Manager 3 and (OSG) Seminar Manager 4 as well as the most recent changelog. Please
note that the manuals are in German. We kindly ask you to use a translator.

The OSG Seminar Manager is a component for the content management system (CMS)
Joomla!. It is dedicated to educational providers.

Using the OSG Seminar Manager, you can list course descriptions on your website. A visitor
can book a course or, if there is no date available, subscribe to an interested parties list for
the course.

In the Joomla! administrator backend, you can manage your courses, course templates,
applications, interested parties lists and tutors. For visitors booking a course, the OSG
Seminar Manager can automatically create an invoice in PDF-format and send it in
combination with a confirmation email. In the backend, you can aso create a list of
participants for each course in PDF-format.

The OSG Seminar Manager can be used different ways. You can either focus on courses
that have known course dates or focus on course templates, so that you create a catalogue
system.
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In the beginning, you should create a list of tutors for your courses, as well as a list of
categories for the courses / course templates. Both will be needed for creating the courses
ad course templates (although a list of tutors is not a must have for a course template). A
course or course template can have more than one category. Tutors have the right to edit
their courses in the Joomla! administrator backend.

If you work with course templates, you can use them in two different ways. You can present
them to visitors as possible courses, for which they can subscribe to an interested parties
list. The other way is using them for in the backend foradministrators or tutors that are linked
to the course. They can use them as a template for new courses they want to create.

After publishing courses or course templates on your web site, visitors can now make
applications for the courses or subscripe to an interested parties list for course templates.
The applications may or may not (this is an option that can be changed) be approved in the
backend, so that changes for the course, e.g. the number of free spaces, are shown in the
frontend.

Installation, Update and Support

7



Version OSG Seminar Manager V2.0.0
Stand 17.08.2012

Installation of the component OSG Seminar Manager

After unpacking the ZIP-file seminarman_vx.x.x_UNZIPME.zip, you will get two additional
ZIP-files: com_seminarman_x.x.x.zip is the component and plg_user_seminarman_1.0.x.zip
is a plugin. You have to install both of them using the Joomla! backend. For each of the files,
enter the file name at Extensions > Extension Manager > Install > Upload Package File in
the Joomla! menu, and click the button Upload and Install.

After installing the plugin, you still have to activate it. In the Extensions Manager, click the
tab Manage and activate the Plugin User - Seminar Manager.

In the menu Components, you can now access the OSG Seminar Manager.

After the installation process, you have to make sure that your web server has write-access
for the following two directories in your Joomla! directory:

JOOMLAROOT/administrator/components/com_seminarman/classes/tcpdf/cache
JOOMLAROOT/invoices

! Please note: When creating PDF invoices, they are saved in the directory
invoices. Make sure, that this directory is not directly accessible via the web
server. You can also use another directory for the invoices, e.g. a directory that
is not located under the document root of the web server. You can change this in
the backend of the OSG Seminar Manager in the Options (top right button):
Options > Invoices > Invoice Directory.

If the installation was successful, you will find the OSG Seminar Manager in the menu
Components > Seminar Manager
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Update of the component

When calling up the OSG Seminar Manager (Components > Seminar Manager), the
overview page of the OSG Seminar Managers is loaded. If you are connected to the internet,
it will automatically show you if there is a new version of the OSG Seminar Manager. If not,
there will be a green check mark and the text "You have the newest version". If yes, there
will be the view as shown in the image above, a yellow arrow and the text "Update found!
Click to update"

To update, you click on the info box and you will be presented a new page. This provides
you with information about what has changed in the new version, a download link etc. If
there is no specific reason against it, you should always update to the newest version of the
OSG Seminar Manager.

Download the new version and install it from Joomla Backend as if a new installation:

Go to Extensions > Extension Manager > Install > Upload Package File in the Joomla! menu

You can define at which release stability you want update notiifications: Go to Seminar
Manager > Options > Misc:
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Installation and Update of modules and plugins

The additional modules and plugins you can download at service.osg-gmbh.de . You can
install it from the Joomla Backend like the component.

Go to Extensions > Extension Manager > Install > Upload Package File in the Joomla! menu,

Go to Search and go to the file you want to install or update. Then click the button Upload
and Install.

Some of the plugins have to be activated at the Joomla Backend. Go to Extensions > plugins
and put into the Search "OSG". You will see all plugins belonging to the OSG Seminar
Manager. Here you can activate them.

Some Extensions have to be activated at Seminar Manager > Options > Extensions:
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Support

If you click the button "Support" in the overview, a new web site will be opened. It contains
information, in what ways we can support you with administering and using the OSG
Seminar Manager.

Forum

The button "Forum" directly leads to the Forum for the OSG Seminar Manager. Here, you
can ask questions and leave comments about the OSG Seminar Manager.

Publishing on the website
You can publish the data of the OSG Seminar Manager by creating a menue item (Joomla >
Menus > New entry) When selecting the menu item type, the OSG Seminar Manager
appears in the list.

There are the following options for linking to the OSG Seminar Manager:

Menu item type: (my) Bookings

Under Bookings, a user finds the bookings, he made. This can e.g. be a menu item "My
bookings", which then displays them. In order to see his bookings, the user must be
registered and logged in.

Menu item type: Category

A course table can be displayed by linking a menu item to a category. Both the upper
category can be selected to display all courses, as well as a subcategory,

At Edit menu -> Options you can select how to show the prices and you can select which
tabs should be displayed in the course table. For example, you can create a menu item that
will display only the archived courses.
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Set everything to No, both tabs will disappear. If at the same time the global setting for the
list of interested parties is set to No, only the category description is displayed under this
menu item. If the global preference list setting is set to Yes, only the interest list is displayed.

Set everything to Yes and activate the list of interests (here Preview / Seat reservation), all 3
tabs will be displayed.

Here the interested parties list is disabled:

To disable the interested parties list go to OSG Seminar Manager > Options > General >
Sales prospect active > No

Course Table - Tab: Dates

An overview of all existing unlocked courses is displayed under the tab: Dates. In front of the
table, the subcategories of the courses are displayed as a link. By clicking on a subcategory
you get the same view, only filtered by subcategory.

When viewing the courses above, you have the option of filtering the courses shown in the
table above. A search can be made in the course titles, the number of displayed courses per
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page can be changed or the courses can be displayed by level (default beginners,
advanced, professionals). Sorting the courses by one of the columns is done by clicking on
the column header.

Link: How the presentation of the table can be designed (showing and hiding columns) is
explained in more detail elsewhere.

The detailed view of a course can be obtained by clicking on the course title. To book the
course directly, you can also click on the link "book now". You can find out how to link the
course title to an alternative site under Courses> Alternative link of the course title

More information: Creating and Editing Courses

Course Table - Tab: list of interested parties

By this tab, the course templates are displayed, on which interested parties (sales
prospects) can be put on a list. The search and filtering of the table is analogous to that of
the price table. The detailed view of a course template can be obtained by clicking on the
course title.

The Price column can be shown or hidden at OSG Seminar Manager > Options > General >
Display of prices....

Link: More information: Use Course Templates as Interest Lists

Course Table - Tab: Archive

You can view archived courses here. More information on archiving courses can be found in
our quick guides.

Menu entry Type: Course

Linking to a single course (course detail view) can also be implemented as a menu item by
selecting Course from the list and then selecting the course to link to.

If the user clicks on Book the booking form opens.

Menu entry Type: Course template

Also, a link to a "course template" can be created directly (as in the course). Here you will
get the view of a single course template. If you want to provide an overview of all course
templates in the price table, create a link using the Menu entry type: Category (see above).

Menu item type: Favourites

Courses can mark a user for themselves by adding them to the "Favorites". A list of the
favourites of a logged-in user can also be linked in the menu.
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Menu entry Type: Tags

Tags are markers which can be added to courses in the backend. E.g. all courses that take
place on weekends, are provided with a day "weekend course". So you could create a link in
the menu to a list of weekend courses. Therefore select the menu entry type "tags" and
select this tag.

The rules for displaying prospect lists and archived courses are the same as for the
presentation of a menu entry of type Category.

Menu entry Type: Trainer List (and Trainer Profiles)

The trainer list is generated via the menu item of the type trainer list. On the trainer list the
image of the trainer (if available), his display name and the description are displayed. If you
click on the link ">> more", you get to the trainer profiles. From this list you can link to a
trainer profile. Next to the image, the ad name and the description of the trainer, the trainer
profile also displays a course table with the current courses given by the trainer.

Important note for hiding a trainer profile in the frontend

The trainer profile can be reached by the visitor of your website in two further ways:

1. via the link of the trainer name on the course description.

If you do not want the content from the "Description" field to appear in the trainer profile in
the frontend of the trainer, you have the following options:

● In the course of a course under "other parameters" > Trainer > Hide. This has the
effect that the trainer name in the frontend is not displayed in the course details and
thus no link to his profile appears. However, if you have created a menu item Trainer
List, the trainer's profile can be reached further.
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● You would like the trainer name to be displayed but no link to his profile is displayed:
By creating a course, at additional parameters > trainer, set the trainer to
"unpublished" . So the trainer will no longer appear under the menu item "Trainer
list".

2. If you do not want the trainer profiles to be displayed via the search plugin, do not activate
the "Search - OSG Seminar Manager Tutors" plugin.

Link More information: Creating and Editing Trainer Profiles

Other ways of publication

You can also publish your events via the modules

"Upcoming events" and "Calendar"

Administration

Applications

If a user books a course in the web frontend, this appliation will appear in the administrator
backend of the OSG Seminar Manager in the tab "Applications". In the overview table, you
can see some of the user's data, course data, the status of the application and the
application date.

In this overview table, you can already change the status of a booking. Click on the status in
the column "State" (here "Submitted"), until the desired status appears. To see a detailed
view of an application, click the last name of the user.

Applications can be published, unpublished or you can put them into the trash. If you put
them into the trash, you can still view them by selecting "Trash" in the status field on the right
on top of the table.

If you want to completely delete an application, you have to enable the option that you are
allowed to do this. If the option is enabled, another button "Delete" will appear in the button
list.
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Detailed View

In the detailed view you can see a tab view with four tabls. The first tab contains the details
about the user that has applied for a course and the course he/she has applied to.

In the first section of this tab, you can change the status of the application. If a course is to
be paid via PayPal, you can also see the PayPal transaction ID here.

A user can also have a Joomla! account built from the input data, if it is enabled in the
options. If there is a Joomla! account for the user, it is shown here. The further details are
given by the user in the web frontend.

The course the user has applied for, is shown in the next section. The data is shown in grey,
as you cannot change the course data at this location. If you want to edit the data, you can
click the button "View Course Details" that leads to the course details.
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In the section "Booking details", you can see the number of attendees and the price group
that has been selected for the attendees. The booking price is computed from the net price
of the price group, and the total net price is computed from the single net price and the
number of applicants.

In the tab "Weitere Teilnehmer", data for the additional applications are shown, in this case
the name and the email address. This tab is constructed from pre-defined custom fields.
They are in German by default. If you delete them or change them, they will disappear here
or the changed fields are shown.
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The same is true for the "Rechnungsadresse", which is also set up from pre-defined custom
fields. In this case, the information inserted is the invoice address of the applicant that gets
the invoice.

On the top right, there are a number of buttons available. Next to the usually present buttons
there is now also the button "Notify".

Using this button, you can send a custom email to the user, that has applied for the course.
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UNew from Version 2.3.0

If the payment via paypal was succesful, the status of the applicant will be set to "Paid"
automatically.

Notifications

If you click the button, you will get a new view:

Here, you can send an email to the applicant. You can also add more email addesses from
the list, if there are more. Additionally, you can add more recipients that get a copy via CC in
the field "send a copy to (CC)". You can attach the invoice automatically by clicking the
select box.

The message itself can be written on the right side of the view. You should enter a subject
and the message.

To send the notification, click the button "Send" in the button list above.
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New from version 2.5.0 - email templates

Email templates and invoice can be selected when contacting applicants. If you send an
email to applications you can select an Email Template.

Um die Nachricht zu senden, klickt man den Button "Absenden" oben rechts in der Leiste.
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Neu ab Version 2.5.0 - E-Mail Vorlagen auswählen

Sie können nun unter Buchungen -> E-Mail versenden eine Vorlage auswählen. Somit
können Buchungsbestätigungen und Erinnerungsmails an mehrere Buchungen nach
Vorlage versendet werden.

! Note: The sender of these emails is the email address of your Joomla! user.
But not for other notification.

Sales prospects

Sales prospects are linked to course templates. A course template is a course that will be
held if there are enough interested people that would want to attend it. To monitor the
demand for a course template, there is the option for users to subscribe to an sales
prospects list for the course template. You can view and also edit such lists of interested
parties in the administrator backend.

In addition to the contact data and the course data you can also see, if an interested person
was already notified about a course or not. You can select and notify interested people, and
also delete them from the list.
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Edit Interested Users

If you click on the last name of an interested person or if you select the box in front of it and
click the button "Edit", a new view will open for a single interested person.

You can see a tab view, that contains three tabs. The first tab includes common information
about the request of the interested person. The second tab shows contact data and the third
tab can contain a comment from the interested user.

In the first tab, the first section is about the account details of the user. Next to the Joomla!
user name you can see the data the interested person has inserted in the web frontend.

In the next section, the information for the selected course template are shown. They appear
grey, as you cannot edit them here. If you want to have a deeper look at the course
template, you can click the button "View Template" and you will get to the course template
view.
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In the last section of the tab you can see, if an interested user has alread been notified.

The contact data of the interested person can be found in the second tab (This is only true if
there you keep the pre-defined custom fields for contact data. If you change them, this tab
will show your changed data.)

In the third tab, you can see a comment the interested person may have inserted for you.

Send Notifications about a new course

The way this is implemented in the OSG Seminar Manager is the following: In the backend,
you can see all people that have subscibed for a sales prospect list * (menu "Components <
Seminar Manager < Sales Prospects" ). The information in the table also includes the course
template (column "Template"), that the user is interested in. You can also filter for this course
template on top of the table.
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* to subscribe to the sales prospects list, users have to subscribe at this place in the
frontend:

preview / seat reservation:

Now if there is a new course available, you can notify the users on this list about this new
course by checking all the users in the list that are interested in the respective course
template and choose the new course for each user in the column "Notification".

If you then click the button "Notify" on the top right, a notification email will be sent to all
selected users.
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The email itself will be constructed using a template, in this case the "Sales prospect
notification" email template. You can find it using the menu "Components < Seminar
Manager < Settings", then the tab "Default email templates".

In the table, you can see at least one email template of the kind "Sales prospect notification"
(see the "Use for" column). Tis template is written in German, so you will want to write an
English default template for English users.

To write your own template, click the link "Add new template" on the bottom of the table.
Writing your email, you can use the parameters on the right side for fields that should be
inserted. You also have to select the right "Use for" in the form above the email, in this case
"Sales prospect notification".

Having done so, save the email template and it will appear in the list. Now you have to click
on the icon in the "Default" column so that this email template is used as a default for sales
prospect notification.
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So the way to go is, in short, set up your email template, select the users you want to notify
from the sales prospect list, then select the course you want to notify them about in each (!)
row and then click the button "Notify".

Wenn Sie sich in das Backend einloggen, dann sind Sie als Benutzer registriert. Diesem
Benutzer ist eine bestimmte E-Mail Adresse zugeordnet. Diese E-Mail Adresse wird als
Absender genannt. Wenn Sie das ändern möchten, dann legen Sie entweder ein weiteres
Benutzerkonto an, mit dem Sie sich anmelden oder ändern Ihre zugeordnete E-Mail
Adresse.

Courses

A course is an event, that takes place at one or more dates. It can be booked using the OSG
Seminar Manager via the web. You can create on course with begin and end date and you
can create several sessions (with own date and time, room (location)) for one course and
publish it on the calendar.

Prerequisites

You have to assign to every event a tutor and a category. Therefore you have to create a
category and a tutor for this event, before you create a course.

Categories can be created clicking the category tab in the OSG Seminar Managers. A
course have more than one category. You can also create subcategories to order your
courses.

Each course can/must have exactly one tutor zugewiesen werden. You can create and edit
tutors using the tutor tab.

Creating a new course

After creating at least one category and one tutor, you can now create a course using the tab
"courses". Click "New" to get the course form.
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The course form has a great number of parameters and options you can define for your
course. The most important ones are described in the following:
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● Published
Publishing a course makes it appear on your website.
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● Title:
The title is a mandatory information for your course. It will appear in full-length on
your web site.

● Alias:
In opposite to the title, the alias is only used for internal linking to your course. If you
do not state an alias, the system will generate an alias automatically when you save
your course.

● Code:
Unique number for your course, can also contain letters.

● Template:
This is the place where you can clone a course from a course template. If you
choose a course template and click the button "Clone", the fields used from the
course template will automatically be filled the form. You also have to choose a tutor.

● Tutor:
Link to the tutor giving the course.

● Start Date/End Date:
The course begins and ends at the given dates.

● Email Template, Invoice Template, Att. List Template
These are PDF-templates. You can edit them in the "Settings" tab.

● Prices
A course can have several prices. The price itself is the net price of the course. The
other prices are calculated from this price using the given calculation rules. They can
be used for different user groups (e.g. club members or a discount group).

● Group, Experience Level
If course attendees have to have certain prerequisites like target groups or
experience levels (e.g. Beginners, Advanced Students), state them here. The groups
and levels are created in the "Settings"-tab.

● Min. attendance and Capacity
These values state how many course participants are at least and maximally needed
so that the course is held.

● Category:
Every course must have a category. If you have not build categories, you can use
the "Default Category".
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● Description:

This description should contain all information that is relevant for a user to be
informed about the course.

Update Version 2.3.6

● Certificate Text:
Certificate is now available for each course, it supports all template parameters of
the attendance list.

There are some more settings that can be defined for a course. In the box "Publish
Information" below on the left, there are a number of options you can open. In the "Details"
area, you can handle the publishing options for the course, meaning in what time frame the
course is shown on your web site.
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The other parameters can be used to make specific decisions for a course, that are different
from the global settings for each course.

Update Version 2.3.6

As an alternative to sessions: New fields and template parameters for start and finish time
of single courses (especially useful for single session courses).

You can manage the view on Misc.

To publish the courses on the frontend you have to create a menu item. You can choice the
menu item types Course, Category and Template

Tab: Allgemein

● Kursfarbe
hier bestimmen Sie die Farbe, mit der der Kurs im Calendar angezeigt wird

● Treffer
Die Treffer können in den Kursdetails angezeigt werden lassen.
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● Freigegeben
Ist ein Kurs freigegeben, ist er auf der Website sichtbar.

● Neu
Falls Ja, dann wird auf der Kurstabelle eine kleine Flagge mit Neu angezeigt.

● Abgesagt
Falls ja, dann wird er Kurs in der Kurstabelle "Abgesagt" angezeigt, wo sonst "Jetzt
buchen" erscheint

● Titel:
Ein Titel ist ein notwendiger Bestandteil des Kurses und erscheint in voller Länger auf
der Website. Er verlinkt von der Kurstabelle aus auf die Kursbeschreibung. Sie
können aber auch eine alternative link to the course angeben.

● Alias:
Im Gegensatz zum Titel dient der Alias nur zum internen Verlinken des Kurses. Wird
kein Alias angegeben, wird beim Speichern automatisch ein Alias aus dem Kurstitel
generiert.

● Kursnr.:
Eindeutige Nummerierung des Kurses, kann auch Buchstaben enthalten.

● Kursvorlage:
An dieser Stelle kann ein Kurs aus einer Course Template geklont werden. Wird
eine Kursvorlage ausgewählt, werden die Daten aus der Kursvorlage durch Klicken
des Buttons "Klonen" in die jeweiligen Felder eingetragen. Ein Trainer muss
ausserdem ausgewählt werden.

● Trainer:
Link zu dem Trainer, der den Kurs veranstaltet.

● Beginn/Ende:
Daten, an denen die Veranstaltung beginnt und endet.

● Vorlage E-Mail, Rechnung, Teilnehmerliste
Hier handelt es sich um PDF-Vorlagen, die unter dem Reiter Settings bearbeitet
werden können.

● Gruppe, Erfahrungslevel
Bestimmt Voraussetzungen an die Besucher des Kurses, z.B. Zielgruppen oder
Erfahrungen (Anfänger, Fortgeschrittene). Die Gruppen und Level können unter
Einstellungen generiert werden.

● Min. Teilnehmerzahl und Kapazität
Bestimmen ab wie vielen Teilnehmern der Kurs stattfindet und wie viele Plätze
insgesamt vorhanden sind. Bitte beachten Sie bei den Einstellungen unter Optionen
> Tab: Allgemein
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● Ort, URL (Ort) und URL (Kurs)
Hier können Sie angeben, wo der Kurs stattifndet. Unter URL (Ort) können Sie eine
Verlinkung vom Ort aus angeben. URL (Kurs) bestimmt eine alternative link to the
course.

● Kategorie:
Jeder Kurs muss mindestens einer Kategorie zugeordnet werden. Soll ein Kurs
einer Über- und Unterkategorie zugeordnet sein, dann bitte BEIDE Kategorien
auswählen. Halten Sie hierfür die Strg Taste fest, während Sie die Kategorien
auswählen.

● Tags:
Tags können Sie selbst definieren und den Kursen zuordnen, die dann im Frontend
unter dem Kurs angezeigt werden.

● Beschreibung:
Die Beschreibung sollte alle für den Besucher relevanten Informationen zu dem Kurs
enthalten.

Tab: Preise

Einem Kurs können verschiedene Preise zugeordnet werden. Der Preis ist der Nettopreis für
den Kurs. Die anderen Preise werden mittels der Rechenregeln aus dem Preis generiert und
können für Mitglieder bestimmter Gruppen von Besuchern genutzt werden (z.B.
Vereinsmitglieder oder als Rabattgruppe).

Weitere Infos zu Preisen:

Pricegroups - Arbeiten mit Preisgruppen (German)

Payment fee - Zahlungsgebühr einrichten (German)
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Tab: Dokumente

● Bild:
Das hier hochgeladene Bild wird über dem Buchen Button auf der Kursdetailansicht
angezeigt

● Dateien:
Diese werden im Frontend unterhalb der Kursbeschreibung zum Download
angeboten.

● Zertifikatstext:
Hier kann das Serienzertifikat gestaltet werden. Mehr Infos dazu erhalten Sie unter
Teilnehmerlisten und Zertifkate

Tab: Veröffentlichung

Hier haben Sie eine Menge Einstellungemöglichkeiten, die die globalen Einstellungen unter
Optionen überschreiben können.

Tab: benutzerdef. Kursfelder

Mit benutzerdefinierten Kursfeldern können Sie Ihre Kurstabellen und Detailbeschreibungen
mit weiteren Spalten und Informationen versehen. Wie Sie die Spaltentitel vergeben und Sie
diese Felder freigeben erfahren Sie unter Optionen > Benutzerdef. Kursfelder

For more information see also Howtos:

Prices and VAT

Attandance List and Certificates
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Sessions

You can create sessions for every event. So you can display every session with start and
end time, duration and location (room) for example like here:

To create sessions go to course overview at the menue courses. Here you can see a column
Sessions.

Click on the symbol of the pages and you can create your first session. Click on new. You
will see this following input mask:
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How to show sessions at the module calendar see here.

Sie gelangen in die Ansicht, in der Sie eine Sitzung anlegen können. Klicken Sie hier auf
den Button Neu.

Jetzt geben Sie die Sitzungsdaten ein. "Dauer" ist ein Freitextfeld, das Sie beliebig füllen
können.

Wenn Sie die Einzeltermine angelegt haben und Sie diese für die Anzeige im Frontend frei
gegeben haben, dann werden diese im Frontend in den Kursdetails angezeigt.

Als Alternative für Eineltermine können Sie auch zu Beginn und Ende eine Uhrzeit angeben.

Ob diese Uhrrzeiten in der Kurstabelle und im Kursdetail angezeigt wird, stellen Sie unter
Optionen > Tab: Misc ein.
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Alternative Verlinkung des Kurstitels

Der herkömmliche Kurstitel in der Kurstabelle verweist auf die Kursdetailansicht. mit der
Option Alternativer Titel Link, haben Sie die Möglichkeit eine alternative URL einzugeben,
auf der der Kurstitel verweisen soll. Dies kann Sinn machen, wenn Sie auf eine
Kursbeschreibung verweisen wollen, die eine andere URL zur Verfügung stellt und über die
auch die Anmeldungen laufen sollen.

Den alternativen Link geben Sie ein unter Kurs bearbeiten -> URL (Kurs) ein

Wollen Sie diese Funktion nutzen, aktivieren Sie diese unter Optionen -> Misc

Für Kurse können ausserdem noch weitere Einstellungen vorgenommen werden. Unten
links in der Box "Veröffentlichung" erscheinen weitere aufklappbare Einstellungsoptionen. In
dem Abschnitt "Details" kann die Freigabe eine Kurses eingestellt werden, also von wann
bis wann der Kurs auf der Website angezeigt werden soll.
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Die anderen Parameter lassen den Benutzer für den Kurs spezifische Einstellungen
vornehmen, die von den allgemeinen Kurseinstellungen abweichen sollen.

Kurse kopieren

Es gibt zwei Möglichkeiten, Kurse mit demselben Inhalt auf eine einfache Art mehrmals
anzulegen:

● das Clonen aus einer Kursvorlage oder
● das Kopieren eines Kurses

Kurse veröffentlichen

Um Kurse im Frontend zu veröffentlichen, muss in Joomla! ein Menüeintrag erstellt werden,
der mit dem OSG Seminar Manager verknüpft ist. Mehr dazu erfahren Sie unter Ausgabe
auf der Webseite

Kurse archivieren

Das Prinzip entspricht dem von Joomla! Artikeln. Archivierte Veranstaltungen können
dennoch weiterhin im Frontend angezeigt werden. Weitere Informationen in unserer
Kurzanleitung Archivierung von Kursen.

Course templates

Course templates are meant to make it easier to create courses, if there are often similar
courses or courses that are held more than once. Instead of creating a course directly, you
can also clone a course from a course template.

Course templates can have more than one (possible) tutor, in contrast to a course, that can
only be assigned to one tutor. You can give a tutor a priority that expresses, how qualified a
tutor is to give a course fitting to the course template.

Another way to make use of course templates is to build a catalogue system, where
interested users can sign up for a kind of course.

Create and edit course templates

A course template is created the same way as a course, but using the menu "Course
templates".
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In addition to a course, a course template also contains:

● a name, that can be used internally and will not appear in the frontend.
● possible tutors, you must select from when cloning the template to

a course. These tutors are displayed in the box "qualified tutors".
You can add and remove tutors for the course template here. If you
want to remove a tutor from the list, check the box "remove" and
save the course template.

Show courses in the interested parties list

There may be courses for which there is no date yet. If it is for example not conceivable if
there will be enough interested people for a course, then it is reasonable to first publish a
course template. For this, the option "Interested parties list" must be active.

If you then publish a category in the frontend, there will be a view with two tabs, one for the
courses and one for the course templates.

Courses can be booked by users. They appear in the tab "Dates". Published course
templates can be found in the tab "Preview/Seat Reservation" without dates. Here, users
can signalise that they are interested in such a course by subscribing to the interested
parties list for that course template.

If you want to publish a course template in the frontend, it must be published:
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If you do not want to use the interested parties list and also not publish course templates,
you can turn it all off using the option "Interested parties list" in the configuration of the OSG
Seminar Manager component.

Categories

You can create and manage categories in the "Categories" tab in the backend of the OSG
Seminar Manager. A course can be assigned to more than one category. You can also
create subcategories to better organise your courses.

Categories can also be used for menus in the frontend. A menu item can link to a category
or a subcategory. (see here, linking a course table).

Tags

A tag is a marker you can assign e.g. to a course. An example is a course that you can
assign to last-minute. For this information, you can create a tag:
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In this overview, next to the title and alias you can also see, how many courses were
assigned to a tag.

If a tag is assigned to a course, the tag will be shown in the course overview (see here).

Tags can also be used to create a menu item, that leads to a course table showing all
courses that have a certain tag assigned.

Tutors

Last update: 2018, 3rd of March

You can create and edit tutors using the menu item "Tutors" in the menu "Components >
Seminar Manager" or if you are already in the OSG Seminar Manager Overview, in the tab
"Tutors".
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The first view is an overview of all already created tutors. Here, you can create a new tutor
(Click the button "New" on the top right side) or edit an already existing tutor (Select the tutor
by checking the box left of the tutor, then click the button "Edit" on the top right).

Edit a tutor

There is now a form for creating or editing a single tutor.

Just at the beginning of the form, you can add course templates to the tutor. For these
course templates, the tutor can then add courses he wants to hold. Choose a course
template from the drop down menu on the top left and press the button "Add / remove". The
course template is then added to the list below. You can remove a course template by
checking the remove box on the right of the course template and again press the button
"Add / remove".

Common information about a tutor are first of all the title, that is mandatory, as it is shown as
a short name for the tutor in the web frontend. The alias and the ordering are optional and
are automatically added by the system if not given by the user.

Additional mandatory information about a tutor are first and last name, as well as the
salutation. Optionally, you can add further titles.
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Optional Data also are company, address and phone data, company type and industry.

A tutor may also have an invoice address. If it is the same as the already given address
data, you can automatically add the data by clicking the blue link "Click here to copy the
input from the Company Information section".
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You should input a textual description of a tutor particularly, if a tutor is to be shown in detail
in the frontend.

You can also upload an image of a tutor, that is also visible in the web frontend.
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A tutor may have a Joomla! account, so that they can see and manage their own courses in
the backend. At this place, you can also link a tutor to an already existing Joomla! account.

You can add userdefined custom fields for a tutor, if the already existing fields are not
sufficient and you want to add more information. The way to add user-defined custom fields,
you can find here.

Tutors Role Seminar Trainer

The OSG Seminar Manager comes with 2 userGroups: Seminar Manager and Seminar
Trainer.

A Seminar Trainer can only see the bookings and courses for which he has been qualified as
a trainer. This qualification can only be done by the OSG Seminar Manager or SuperUser.
Joomla SuperUser und Seminar Manager can customize the role of the tutor.
Create the user groups at OSG Seminar Manager > Settings > State/Upgrade.

To customize the role of the tutor go to Options > Tab:Tutor's Role

Users - Booking Rules and Cancellation

From OSG Seminar Manager version 2.10.1
Last update of the documentation - 7 March 2017

At the OSG Seminar Manager you will find the menu item Users. Here you can for every
Joomla! user define and assign user booking rules

More information see our brief instruction User Management - booking rules and cancellation

Settings
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Additional Options - Settings

You find the tab "Settings" in the overview (called Settings from now on).

You can see another tab view with the following tabs:

● Main Settings
In this tab you can administer the user-defined fields and the stylesheets of the OSG
Seminar Managers.

● Reference Tables
Such reference tables are for example lists of countries, experience levels or other
groups, that are used in different menus.

● Default Email Templates
Here you can create or change E-Mail templates.

Email Templates

For Emails that are sent by the OSG Seminar Manager, there exist already pre-defined
templates. There is a template for booking confirmation and one for sales prospect
notification.

Go to "Settings" ->"Default Email Templates". Here you see templates for Booking
confirmations an Sales prospect notification.

If you need a different template, you can click the link "Add new template" to get a new page:
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Here, you can add the content of the email in the field down below. Parameters, that should
be added from attendee data, are listed on the right side. As an example, you can look at a
pre-defined email template.

! Note: Recipient and BCC only accept the parameters {EMAIL} and
{ADMIN_CUSTOM_RECIPIENT}, {TUTOR_RECIPIENTS} and real email
addresses. Custom fields don't work here. Only Subject and Body accept
custom fields.

More information about email configuratione see Options - Default

● PDF Templates
Templates for invoices or participant lists can be administered here.

● Export Data
You can export data here, to use it in other softwares.

● Price Groups
Different price groups for members of certain groups (e.g. club members or other
discount groups) can be created and managed here.

● Start / Upgrade
Here you can create the two user groups "Seminar Manager" and "Seminar Trainer".
Then you can create user and assign them to the user group "Seminar Trainer" or
"Seminar Manager".
Now you can log in as "Seminar Trainer" or "Seminar Manager" and see what is
possible.

● Info
You can find informationen about the installed version of the OSG Seminar
Managers here.

+++++
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Options

Additional Options - Options

If you open the tab "Settings" in the overview of the OSG Seminar Manager, you will se the
button "Options" on the top right side. There are plenty of different setting possibilities for the
OSG Seminar Manager you can open here.

When you click the button, a window opens that shows a new tab view with different options:

Tab: General

In this tab you can defined basic options of the OSG Seminar Managers:

Enable Bookings

If you check "No", visitors of the web site cannot book courses. This makes sense, if the
OSG Seminar Manager should be used as a catalogue system, meanin courses should just
be listed.

If visitors are able to book courses, you can choose following options
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● "Registered users" (these have to log in before)
● "All users" (this means that users that book a course also get a Joomla! account,

Requirement: Joomla User Management allows User Registration)
● "All users (without user registration)" (a user that books a course will not

automatically get a Joomla! account)

Show Login Form

If you show the Login Form, a visitor can log in and get access to his own data, e.g. courses
he has booked or his favourite courses and course templates.

Multiple Applications per User

Using this option, a user can book a course more than once. This can be necessary, if a user
wants to book a course for another person.

Applications deletable

You can decide here, if you want to be able to fully delete an application. If applications are
not deletable, it is only possible to move them to the trash. The trash can still be viewed.

Applications for multiple attendees

Here you can decide, if a user can only book for one person (choose "No" or also for more
than one attendee ("Yes"). The added attendees will not get a Joomla! user account, and
also they will not have the full data set saved.

Prices

The OSG Seminar Manager has 5 possible price groups. At this place, you can define what
prices are shown to the curret user. The first price is always visible for everyone. It can only
be defined if you want to show the gross and net price or just the price group title.

For all other price groups, you can decide to not show them at all (choose "Nobody"), for
"Assigned groups" or "All users". You can also just show the name of the price group for
each of them.

Display of prices in the interested parties list

Here you can turn the interested parties list on or off. If it is active, users can subscribe for
course templates.
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Show Payment Overview

In Germany, it is required by law (see for example here), that after entering the ordering data
(as for a course), you have to show a payment overview. On the payment overview page,
the basic price, the price with added VAT and the total price (e.g. if there is more than one
applicant) is shown.

If you do not need the payment overview (e.g. for non-German web pages), you can turn it
off here.

Site after application

You can define the page the user gets to view after he has booked a course.

Modified Date and Time

You can show the modification date and time for a course or course template in the frontend.
For this, click "Yes".

Show Hits
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The "Hits" are the number of times a course web site (course table) was clicked. If you select
"Hide" here, the number of hits is no more shown, but still the hit counter is active.

Show Sessions

You can define sessions, that is single course sessions, for a course. You can do this in the
administrator backend for a course overview. There is a column "Sessions", viewable using
the linking icon:

The defined sessions can then be viewed at the course overview:

If you do not want to show sessions, you can turn them off here.

Show Tags

Tags are marker, that can be attached to courses. If you do not need tags, you can turn them
off here (click "Hide").

Show Favourites

Here you can turn the favourites function on or off. If turned on, you can see an icon on the
course page, that leads the user to his/her own favourites (if the user is logged in). Another
icon can be used to add the current course to the favourites of a user.

Show assigned Categories

Using this option, you can decide if the assigned categories are to be shown in the course
view or the course template view.

Show Hyperlink

Here, you can decide if in a user's personal application overview and in his/her favourites, a
link to the assigned course should be shown.

Show Experience Level

If there are courses for users with different experience levels (e.g. beginners, advanced
etc.), you can make these experience levels visible if you choose "Show". You can edit the
experience levels here: Settings - Experience Levels.

Show Location
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The course location can be turned on or off here. The places that are affected by this
decision are the course table (the column "Location" will disappear if you choose "Hide"), the
course overview and the course template ("Location" also disappears if you click "Hide").

Show Group

User groups are next to the experience levels an additional method to define properties, an
applicant to a course should have. These can also be edited . If there is no relevant grouping
for the applicants, you can turn this view off ( click "Hide").

Show Tutor

Tutors are not only represented in the frontend, but they do also have rights in the backend,
if they can log in and are assigned to the user group "course trainer". You can assign a
Joomla! group to a tutor at the tutor page.

Course Total Capacity and Current Capacity

The total capacity of a course it the number of places for course applicants. The current
capacity is the number of free places that can still be booked. This is not always the same as
the real number of free places.

Szenarios if Course Total Capacity is set to "Show"

● Current Capacity = Hide -> the number of booked seats in the front end will not be
displayed. The free course places may be overbooked at the same time.
Display: Seats: 2

● Current Capacity = "Show (all states)", the current capacity will be decremented with
every made application. If the application is not approved, e.g. the application is set
to "canceled", the capacity will be increased again.
Display: Seats: 2 of 5

● Current Capacity = "Show (only state "Pending" and "Paid")", the capacity will not be
changed for every made application, but only after the status of the application is set
(at backend) to "pending" or "paid". Users can apply for the courses until the number
of approved places is the same as the total capacity of the course. Overbooking ist
possible.
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Filter Box

This box is shown on top of the course table to let the user filter and search the courses. If
you do not need this function, click "Hide".

Limit Box / List Limit / Category List Limit

The limit box defines, how many courses are to be shown on each page for the course table.
If there are more courses, a navigation is shown below the course table. The option list limit
is the pre-defined amount. Category List Limit has no function at the moment.

Ordering

Defines the ordering of courses / course templates in the course table view. Possible
orderings are title (alpha-numeric), course start, or ordering, meaning ordered by creation
date.

Print / Email Icon

If you check "Show", icons will be shown on the web site for the respective functions:

State Icon

no function at the moment

For each feed course show
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no function at the moment

Tab: Defaults

Further settings for prices can be defined here:

Currency

The basic currency for prices for cources etc. The default is EURO.

show 2. currency

A second currency can be shown for the courses etc. Prices are defined in the basic
currency, so the price in the second currency is computed via the exchange rate.

Send Email To Address

This is the email address that is used for the OSG Seminar Manager component.

! How to configure email settings: This email address gets copies of sent
emails in following cases:

● bookings on interested parties (sales prospects) and
● courses notifications,
● sales prospects notification,
● also this email address gets an information about successfull payments

via paypal.

If this field is empty no email will be send. This rule only applies for bookings on
interested parties and courses if the parameter
{ADMIN_CUSTOM_RECIPIENT} is written on BCC or recipient. Exception: if the
parameter {ADMIN_CUSTOM_RECIPIENT} is overwritten by valid email
address this valid email address will get emails about this bookings - although
this field (Send Email To Address) is empty.

More information here Settings - Email Templates and applications - sender of
emails

VAT rate

The VAT rate for booking a course. For Germany, the current VAT rate is 19%, which is
pre-defined here.
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Tab: Invoices

When a visitor books a course, the OSG Seminar Manager can automatically send an
invoice.

Create invoices

If you choose "Yes", invoices are created if a visitor books a course. The invoice is saved in
the given directory.

Attach to booking confirmation

With this option you decide, if you want to attach the created invoice to the booking
confirmation email. For this, you also have to choose the option "Create invoices".

Invoice directory

This is the directory, where invoices are saved.

First invoice number

This is the first invoice number of the first created invoice.

Tab: Uploads

Uploads are files like PDFs or images that are shown or linked on web sites.
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Legal Extensions - File Types

A List of file extensions, that are allowed for uploading.

Set maximum file size

Maximum file size for uploading a file (in byte)

Path to files folder

The place where you can find the uploaded data.

Restrict Uploads

Here you can defined, if uploaded data has to be conform to the allowed parameters. If they
are not, there will be an error shown.

Check MIME Types

If set to "Yes", uploaded files have to end on one of the allowed filetype extensions. For this,
the legal and illegal MIME types defined below are used.

Legal Image Extensions - File Types

Defines what file types are allowed for images.

Image Width / Height
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Uploaded images are skaled so that they have the defined image width or height (depending
on which value is larger).

Path to Image Folder

Location of uploaded images.

Legal / Illegal MIME-Types

Lists of allowed and not allowed file type extensions, that are used to check uploaded files.

Tab: Payments

The OSG Seminar Manager supports payments using PayPal. To activate this, "PayPal
active" must be set to "Yes" and there has to be a "PayPal Email Address".

Tab: Custom fields

User-defined fields for the course table and course detail view - Every field can have a
title and a text. This way, the course table can get additional columns and the detailed view
includes more information. At Options > Tab > Custom fields you can edit titles and decide, if
they should be visible in the frontend (course table and/or detailed view).
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Above that, you can choose the course table layout. There are three different layouts
(order of the table columns) for the course table:

The option Standard shows the following order:

The option Interlaced 1 shows the following order:

The option Interlaced 2 shows the following order:

Editing a course, there is a tab Custom fields, Here, you can fill in the content of the fields.

There are the same parameters for the PDF and email templates. They are called:

{COURSE_CUSTOM_FIELD_1}: The 1st custom field for the course

{COURSE_CUSTOM_FIELD_2}: The 2nd custom field for the course

{COURSE_CUSTOM_FIELD_3}: The 3rd custom field for the course

{COURSE_CUSTOM_FIELD_4}: The 4th custom field for the course

{COURSE_CUSTOM_FIELD_5}: The 5th custom field for the course

Tab: Misc

Section: Theme settings

(New from version OSG Seminar Manager PRO 3.1.0.0)
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Here you can set an optional grid layout for the display of categories, tags or the trainer
table. This layout needs Bootstrap 3.

Example for a grid layout:

Following settings and some more are availabe:

Section: course table

Seings for the display of your course table (every layout)

it is now possible to hide the two columns "end date", "finish date" and "price".
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Also you can hide or show the time of begin and end date.

Section: My bookings

Here you find the options about the view of the menu type "bookings" and about the
cancellation of their bookings.

More about it also see our documentation about Booking Rules and Cancellation

Also you find a lot of other options like options for the company details of the trainer and
much more.

Modules and Plugins

Plugin Manual Application and Invoice

You can download the plugin "Manual Application and Invoice" and all other modules and
plugins from service.osg-gmbh.de/en

With the Component "OSG Seminar Manager" applicants can book an event from the
frontend and you can create an invoice at the time of the booking.
The plugin "Manual Application and Invoice" enables an administrator to book an application
manually from the backend and to create an invoice for one or a number of applications at a
time individually chosen.
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Activation

1. After installation activate the plugin "OSG Seminarman Advanced Booking" at Joomla! ->
Extensions -> Plugins.

2. Also you have to set it to "Yes" - Settings -> Options -> Extensions

In the backend, you will see an updated application view including two new buttons,
"Manually create Invoice" and "New".

Manually Creating a new Application

To create a new application, you first have to select a course from the course list, for which
the person you want to book wants to apply. Then click the button "New".

You will get an application form, that now allows you to create a new application.
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You will have to fill out fields for the status of the application, the account information (for the
booking and the applying person), as well as the application details. In the application
details, the fields "Booking price (net)" and "Total price (net)" will be computed from the fields
"Number of Attendees" and "Pricegroup". They cannot be changed manually.

The course details are only displayed and can also not be changed manually. To select
another course, you will have to "cancel" your application and create a new one when you
have selected the other course.

Next to the tab "Application", you can see a tab for the default user-defined group
"Rechnungsadresse" in the OSG Seminar Manager and the comment field. Note that, if you
have user-defined groups for the application form, and these include "mandatory" fields, you
will have to fill them out before you can save the application.

After saving the new application, it will appear in the application overview. When creating a
new application, there is no invoice created. If you want to create an invoice for this
application, you will have to do this manually.
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Rebook (new from plugin-version 1.5beta3)

At Application (advanced)click on the application you want to rebook.

At "course details" - Course title you can choice a new course.

You see the categories and can click on a course you want to rebook the applicant to

If you click on "ok" the old application will be cancelled and a new booking will be done

After rebooking you can assign the price / Price group.
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Important hint: If you perform a rebooking, the booking price of the original booking is taken
over. To change that price to a price that fits to the new course, you will have to edit the
booking: Choose the respective price group and press the save button. Create an invoice
only after saving the correct price group for the rebooking.

Manually Creating an Invoice

You can create invoices at two places. In the application overview, you can create invoices
for a number of applications at once. In the detail view of a single application, there is also a
button for creating a single invoice.

In the application overview, you can select the applications using the check boxes at the
beginning of the lines. Then click the button "Manually create Invoice".
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In the application detail view, there is also a new function "Manually create Invoice". This
function is placed in form of a button next to the status field on top of the form.

Plugin "Extra Charges"

This Plugin enables to display one further price (extra charge) additionally to the event price.
E.g. you can offer to book catering. The extra charge is applied as a fee per registered
person, just like the course fee.

Features:

● Every event can have its own extra charge
● The extra charge can be selectable or not selectable
● The extra charge will be displayed at the payment overview
● The extra charge can be displayed at emails and invoices
● The VAT rate may vary from event VAT rate

Settings

After the installation of the plugin enable it: Extensions - Plugins - OSG Seminar Manager -
Course Extra Charges

If you edit a course you can add an extra charge

If extra charge is not selectable the price at the course table will be shown inclusive the extra
charge
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At course detail view both prices will be shown separately

At the booking form the extra charge is not selectable

If extra charge is selectable it can be selected or rejected
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Plugin Advanced Export (plugin)
This plug-in extends the CSV export feature of the OSG Seminar Manager.

With the plugin export templates can be created, which pull only specific columns from the
database. These column headers can be also renamed in order to obtain a clearly arranged
CSV export.

You can download the plugin and all other modules and plugins from our download area.

Settings

After installation acitvate the plugin at Joomla -> Extensions -> plugins. Then you can
create templates for the export of courses or bookings.

At Seminar Manager -> Settings -> Export -> CSV Export you see two tabs: Export data and
Edit templates.

At Edit templates you can create 3 templates for the export of courses and 3 templates for
the export of bookings.

Put in a template's title and then select the column types and name the column heading.

Don't forget to save.

Now you can see the templates at Eport Data.
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Module Upcoming Events

This module will display the upcoming events.

You can download the module "Upcoming Events" and all other modules and plugins from
our download area.

Also see Demo Modul "Upcoming Events"

Settings and frontend views

After installation this module you can find at Joomla > Extensions > Modules.

You have a lot of options in the backend, for example the number of shown dates, the shown
categories and others.

In the basic options, you can choose, which categories of courses you want to show.
Additionally, there are fields for the number of courses that should be displayed, and the
number of days before a course begins. There are the options "simple list" and "extended
list" for the layout.
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In the options for the simple list, you can select the layout and if the course numbers are to
be displayed.
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A simple list view may look like this:

In the options for the extended list (in a table view, see above), the fields end date, location
and price may be turned on or off in the view.
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A table view (extended list) of the upcoming events may look like this:

Exampls of the settings

We assume, today is the 3rd of Sep 2013

Case 1

Upcoming days: 20
Beginning of the course from: 20th of Sep 2013
Beginning of the course till: 30th of Oct 2013

=> Courses beginning from 20th of Sep 2013 till 09th of Oct 2013 are displayed, but no
courses beginning later than 30th of Oct 2013

Case 2
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Upcoming days: 60
Beginning of the course from: 20.09.2013
Beginning of the course till: 30.09.2013

=> Courses beginning from 20th of Sep 2013 till 30th of Sep 2013 are displayed, but no
courses beginning later than 30th of Sep 2013

Case 3

Upcoming days: 20
Beginning of the course from: no specification
Beginning of the course till: 30.09.2013

=> Courses beginning from today till 22th of Sep 2013 are displayed, but no courses
beginning later than 30th of Sep 2013

Case 4

Upcoming days: 20
Beginning of the course from: 20.09.2013
Beginning of the course till: no specification

=> Courses beginning from 20th of Sep 2013 till 09th of Oct 2013 are displayed

Case 5

Upcoming days: 365

Number of Courses: 20
Beginning of the course from: no specification
Beginning of the course till: no specification

=> All courses (but max. 20) beginning from today till 3rd of Sep 2014

Plugin Additional PDF lists

Tis plugin offers two more pdf lists for the component OSG Seminar Manager, e.g. for use as
name badges.

How to use additional attandance list as name plates

! Note: For this feature you need the plugin "Additional PDF List". this plugin and all the
other additional plugins and moduls for the OSG Seminar Manager, you can download from
our download area. You need an OSG Seminar Manager Premium Membership.
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After installation and activation the plugin go to Seminar Manager -> Options -> Extensions.
Activat the plugin.

Now you can create a new pdf template. Got to Seminar Manager → Options → PDF
Templates.

Here you can create a new pdf template or select one. Look at the id of the template. You
find the id at the end of the URL:

Got to the plugin and fill the id and a name (this name will have the button).
Now go to OSG Seminar Manager → Courses, choose a course (1) and click the name
plates button (2).

Save the generated PDF document (1) and opened with Adobe Reader (2).
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Print the document (1) and use the following settings for the desired layout (2).

Create Certificates

There are two ways to create certificates: you can create series certificates and single
certificates.
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1. Create series certificate

You create and design the certificate at" course" or "course template". You can use all
template parameters of the attendance list.

How to use the parameters you see here: email templates

To create the certificate: OSG Seminar Manager → select a Course (1) → click on
"Certificates (PDF)" (2)

Then you can print or save this PDF document.

! Tipp: If you don't want to design every single certificate then create the certificate at the
course template. You can copy this certificate if you clone a course of a template. You can
also copy the source code to the next certificate template.

The order of the print you set here: Misc.
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2. Create a single certificate

Create certificate templates for single certificates per booking using PDF templates -
There is now another option available to create a certificate for a course applicant. Up to
now, it was only possible, to create a certificate for all course applicants at once. These
certificates were then created in one single PDF document. New is the option to create a
certificate for a single booking.

1st Step: First of all, you should create a template for the certificates. Either you use the
pre-defined template and edit it or you create a new template. You can find the templates at
Settings > PDF templates.

HERE you can find how to create and edit a template. The field use for must be set to
"Certificates".

2nd Step: Connect the template to the courses

Choose the respective template in "Edit course"

As default, -Default- is selected. This is the template, that has the star attached to it:

If you want to use another template for this course, choose this template in the select box.

3rd Step: You can decide, if a user can see his own certificate under MyBookings.

You can change this under Options > Misc > MyBookings > Show certificate.

Now, you can create certificates: Go to your bookings overview. Select the bookings for
which you want to create a certificate. Click on the button "Generate certificate" top left. If a
booking already has a certificate, it will be overwritten.

Note: There can only be one certificate per booking.

*Important notes for processing of certificates and name plates

1. The PDF creation is optimized for the JCE Editor. No other editor should be chosen, for a
faultless performance (eg correct pagination).

2. Components → JCE Editor → Global Configuration

„Validate HTML“ must be deactivated.
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3. In relation to the source code view of the editor:
class="{LOOP}"

Provides a loop through all course participants and should not be removed.

<br pagebreak="true" /><br />

Provides a page break after each certificate and should not be removed.

Plugin Vote

You can allow the users to vote for the course templates which are published on the
interested parties list. This rating can be seen by visitors or registered users. The
evaluation can be approved anonymously or made dependent on an entry in the list of
interested parties.

Acitivate the pluging

First unzip the package. Then install these two plugins.

Activate both plugins at Joomla > Extensions > Plugins
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Configuration

At Joomla > Extensions > Plugins you have to configure the plugin.

Interested Party

● Rating only with registration:
If Yes, the rating will be sent only if the registration form is submitted, if No, the rating
could be sent without a registration to the interested parties list.

● Short desc about voting:
If Yes, there will be a short description at the course table: "Please give your rating to
following objects."

● Reg. Form after Rating:
If Yes, you only can subscribe to the interested party list AFTER voting (required:
Rating only with registration is set to No) In this case the vorting is displayed on the
course detail page.
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● Form FiIling:
If No, the standard fields of the booking form for the interested parties lists will be
hided, only the custom fields will be shown furthermore. So you can subscribe to the
list anonymous. Set Rating only with registration to Yes, if you want the user to fill in
the custom fields wtih the rating.

Course

Voring for courses is not available yet.

General Settings

● Rating Access:
If Registered only registered and logged in users can vote. Public users can see, that
a voting is possible but cannot vote.
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● Enable Half Stars:
You can vote for half stars.

● Initially hide rating results:
The user can see the result of the rating after he has sent his rating. If No he can see
the average result of the rating before he sends his rating. (Requirement: Display of
the rating results is set to Average value)

● Bewertungsintervall:
After how many minutes a user can vote a course from the same IP address
(Requirement: Rating Access is set to Public)

Bewertungen einsehen

Anonyme Bewertungen mit Ausfüllen eines Anmeldeformulars werden im
Administrationsbereich unter Interessenten erfasst. Als Vorname und Nachname wird
Bewertung angezeigt und als E-Mail Adresse die der Joomla Konfiguration

Alle Bewertungen von Kursen aus Interessentenlisten werden im Administrationsbereich
unter Kursvorlagen erfasst.

Unter Kurs bearbeiten sehen Sie eine detaillierte Übersicht der Bewertungen

Hinweise zur Anpassung der Bezeichnungen im Frontend

Folgende Sprachparameter könnten Sie nach eigenen Wünschen eventuell noch umbennen
(unter Joomla > Erweiterungen > Sprachen > Overrides > Für Site

Eintragen-Button umbennen mit: COM_SEMINARMAN_JOIN_LIST
Interessenenlistenbeschreibung umbennen mit:
COM_SEMINARMAN_LST_OF_SALES_PROSPECTS_DESC
Auf Interessenenliste eintragen umbennen mit:
COM_SEMINARMAN_ON_LST_OF_SALES_PROSPECTS
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Module Calendar

The calendar view will show the course data saved in the OSG Seminar Manager in form of
a calendar. You can show the event on the calendar from the begin to the end or show
different sessions of the course.

You can download the calendar and all other modules and plugins from our download area.

After installation this module you can find at Joomla > Extensions > Modules.

Settings

At the module OSG Calendar you have following settings:

Sessions based: if No, the calendar will display the course from start date to finish date. If
Yes, the calendar will display the sessions of the course - if a course has no sessions, the
couse will displayed from start date to finish date.
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How to create single sessions for a course see courses > sessions

According to the Layout you have additional settings for the table view at the tabs: Mini
Calendar Options and Standard Calendar Options:

You can also define a color for the presentation of the course at the calendar. This color you
define at Courses > tab:General

Example of the view on frontend:
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Brief instructions

Attandance List and Certificates

Attandance List

To repeat certain rows in the attandance list you have to use the LOOP function.

If you download the OSG Seminar Manager, you already have a template for the attandance
list with LOOP function.

Unfortunately, it happens again and again that this function is deleted or moved.

NOTE: Please ensure that <thead> and <tbody> are correctly defined for a clean and easy
to read table, even with a long attendance list over multiple pages.

Example:

<table>
<thead>

<tr>
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<td><strong>Lastname</strong></td>
<td><strong>Firstname</strong></td>
<td><strong>E-Mail</strong></td>
</tr>

</thead>
<tbody>

<tr class="{LOOP}">
<td>{LASTNAME}</td>
<td>{FIRSTNAME}</td>
<td>{EMAIL}</td>
</tr>

</tbody>
</table>

Here you can download the original source code from which you can see where the LOOP
function must be put.

Download of example of the source code of the attandance list (pdf, 35 KB)

How to use additional attandance list as name plates

! Note: For this feature you need to activate the plugin "Additional PDF List"

Here you find the documentation about how to use additional PDF lists .

Create Certificates

There are two ways to create certificates: you can create series certificates and single
certificates.

1. Create series certificate

You create and design the certificate at" course" or "course template". You can use all
template parameters of the attendance list.

How to use the parameters you see here: email templates
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To create the certificate: OSG Seminar Manager → select a Course (1) → click on
"Certificates (PDF)" (2)

Then you can print or save this PDF document.

! Tipp: If you don't want to design every single certificate then create the certificate at the
course template. You can copy this certificate if you clone a course of a template. You can
also copy the source code to the next certificate template.

The order of the print you set here: Misc.

2. Create a single certificate

Create certificate templates for single certificates per booking using PDF templates -
There is now another option available to create a certificate for a course applicant. Up to
now, it was only possible, to create a certificate for all course applicants at once. These
certificates were then created in one single PDF document. New is the option to create a
certificate for a single booking.
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1st Step: First of all, you should create a template for the certificates. Either you use the
pre-defined template and edit it or you create a new template. You can find the templates at
Settings > PDF templates.

Hw to create and edit a template. The field use for must be set to "Certificates".

2nd Step: Connect the template to the courses

Choose the respective template in "Edit course"

As default, -Default- is selected. This is the template, that has the star attached to it:

If you want to use another template for this course, choose this template in the select box.

3rd Step: You can decide, if a user can see his own certificate under MyBookings.

You can change this under Options > Misc > MyBookings > Show certificate.

Now, you can create certificates: Go to your bookings overview. Select the bookings for
which you want to create a certificate. Click on the button "Generate certificate" top left. If a
booking already has a certificate, it will be overwritten.

Note: There can only be one certificate per booking.

*Important notes for processing of certificates and name plates

1. The PDF creation is optimized for the JCE Editor. No other editor should be chosen, for a
faultless performance (eg correct pagination).

2. Components → JCE Editor → Global Configuration

„Validate HTML“ must be deactivated.

86



3. In relation to the source code view of the editor:
class="{LOOP}"

Provides a loop through all course participants and should not be removed.

<br pagebreak="true" /><br />

Provides a page break after each certificate and should not be removed.

Template of a certificate

Download of example of the source code of a certificate (pdf, 50 KB)

Extend and edit booking forms - by custom fields

The data fields at the registration form can largely be adjusted by yourself. However, the
fields Salutation, Title, First name, Last name and E-mail address are permanently installed
and can not be edited or hidden.

However, you can edit the options for the Title field by selecting the "Reference tables" tab in
the Settings menu and clicking "XML tables". There you can add more <value> elements
below <title> Salutation </ title>.
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Custom fields

The custom fields can expand the enrollment forms for courses (applications) and prospect
lists, or the trainer profiles.

You can create fields and groups at Settings > Tab: Main Settings > Custom fields.

Groups must be assigned to the areas of applications, sales prospect or tutor profile (Use for
...), the custom fields must be assigned to the groups again.

An example is the (already preset) group Billing Address, which is assigned to the area
Applications. This group then contains fields such as street, zip code, city etc.

At the booking form you see the group Billing Address and the custom fields:
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If, for example, you want to assign an additional area to the registration form, such as
Teilnehmer / attendees, first create the group Teilnehmer / Attendees and then assign this
group to bookings -> Use for - Applications.

After that you can create the custom fields and assign these fields to the group Teilnehmer /
attendees. For example:

Now the booking form is expanded:

At the administration area you can see these fields at bookings. you can see a new tab:
Teilnehmer / Attendees:
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! Note: published: visible at backend / editable and available as parameters for PDF or
e-mail.
published and visible: visible frontend / editable when Applications & Sales Prospects, visible
from the frontend of the trainer profile

If you already have bookings or sales prospects you should not delete published fields
otherwise the datas of these fields are not available anymore.

In this way, e.g. also the trainer profile can be expanded with more information. First of all, a
group has to be created, which, e.g. describe the hobbies of a coach. There you can insert
fields like "Sporting activities" or "Musical skills".

Accept TOS checkbox and Confirmation Checkbox

These two fields are custom fields. The checkbox for accepting the terms and conditions is a
custom field. This field is always displayed before the booking button, it can not be moved

If you want to use a field of this type, you can use the field of the type Confirmation
Checkbox. This checkbox will always be displayed within the booking form.

For both fields, enter the link to your article with an href attribute.

Edit and assign email templates - booking confirmations

Emails to interested customers and bookings can be generated from a template, which you
can adjust at Settings> Tab: Email templates in the backend. You can create several email
templates that you can assign to different courses. Look for the template that will be used to
notify interested customers or to confirm the booking.

During the initial installation, we provide you with pre configured e-mail templates for booking
confirmation and for notifying interested customers and waiting list participants, which you
should adapt to your needs.
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You can edit the template by clicking on it. On the right side you will find a list of parameters
that will be replaced in the specific e-mail with values   from the corresponding course
template or from the registration of the interested party. These parameters can be used in
the subject line or in the content.

If you want to create a new template, the link "New template" leads to a new page:

The text can be entered here below. The parameters that can then be inserted from the
customer data or others are listed again on the right side. As an example, you can see the
preset email templates. Don't forget to use the right selection.

With the parameter {TUTOR_RECIPIENTS}, all tutors assigned to the course receive a copy
of the booking confirmation.

How to configure the basic settings for sending e-mails see Options> Tab: Defaults.

You can find out how to send e-mails in our documentation on Notifying Participants (Link ist
missing)

User Management

From OSG Seminar Manager version 2.10.1
Last update of the documentation - 7 March 2017

At the OSG Seminar Manager you will find the menu item Users. Here you can for every
Joomla! user define and assign user booking rules according to the following scheme:

The categories in which he can book courses and the number of courses in this category.

The period within these courses take place.
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Booking Rules and Cancellation

In the following we describe how to create booking rules for users and how to allow users to
cancel a booking.

How to create booking rules for users

For each Joomla! user, you can create rules using the following pattern:

You can define the categories for courses he is able to book as well as how many courses
he can book per category. Also, you can defined the time period in which the courses take
place.

Activating the user management – options in the backend

To be able to create the rule, you will first have to change the following options in the OSG
Seminar Manager Einstellungen: At Settings > Options > Tab "General you set „Enable
Bookings“ to „Registrated users“. To have the rules to show up at the menu point „My
Bookings“ (for booking statistics), set the „Enable booking rules“ to „Yes“ in the same menu.

Defining the rules – Settings in the Backend

To define a rule, go to OSG Seminar Manager > Users

Here, you get an overview of all Joomla! Users. For each user, you can manage the booking
rules:
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To create a new rule click on „Manage booking rules“. The following screen will open up:

Enter your rules here. The „Title“ is user-defined and will appear later using the menu
„Bookings“ and also in the notice after logging in.

After saving, the rule appears at „Show booking rules“ and „Manage booking rules“

At „Show booking rules“, you can also view the number of courses a user has already
booked (8/25 means that he has booked 8 out of 25 courses).

! Attention: It is possible to have two rules for the same category or for overlapping time
periods. Nevertheless, you should absolutely avoid to do this. If you do this, the booking of
a course would count for both overlapping rules.

Menu „Bookings“ - Views for the Joomla! user

If a user should be able to see his own bookings, you need to create a menu of the type
„Bookings“. Here, a user can see his „Booking statistics“ and therefore his booking rules and
his already booked courses.

Allow users to cancel their bookings

To allow users to cancel their bookings, go to Seminar Manager > Options > Tab:Misc. > My
Bookings in the backend.
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Allow Cancel

You can define here, what status a booking has to have so that the user can still cancel it. A
booking with the status „paid“ can never be cancelled.

Cancellation deadline

You define here, how many days before the course starts, a user can still cancel the
booking. If you for example set this value to 1, it is still possible to cancel 24 hours before the
course begins. If the course has no starting hour, the system will use 0:00 am as the starting
hour.

If you allow the user to cancel a booking, the user can see a Cancel button using the menu
My Bookings

If the user clicks Cancel, he has to confirm the cancellation again:
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If he confirms the cancellation, the booking will get the status cancelled:

Waiting list - settings and handling

From version 2.12.5RC1

Activate the waiting list function

Working with a waiting list, is only possible, if you have activated the plugin "Manual booking
and invoice". If you would like to use the waiting list function in the frontend, activate the
function at OSG Seminar Manager > Options > Extensions:

Important note:

If you let overbook a course, there is no waiting list shown although you have activated it.
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To overbook a course you have made following setting at Options > Tab:General >
Calculation of current capacity: No calculation.

Click here to learn about the context of showing a courses' capacity and overbooking a
course:

Frontend procedure

There are two use cases in which the user gets to access the waiting list in the frontend:

1. The course is fully booked.
2. The user wants to book more places than available.

If the course is fully booked, the user will already see in the course table, that the course is
fully booked. At the same place, a link will be shown that lets the user access the waiting list.

If a course is not yet fully booked, but the user wants to book more places than still available,
the user is also pointed to the waiting list. The user can then book all applicants to the
waiting list or book the course with a lesser number of applicants.
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Please note: the requirement for the display of the view above is following: at the course
detail view the actual capacity is shown. (Options > Tab:Misc > Section:Courses) If the
capacity is not shown then the applicant gets a notice at the end of the of the registration
process: Your booking could not be received. The number of places booked is larger than
the number of free places.

If a user wants to apply to the waiting list, he first has to fill out the application form. After
that, the user has to confirm the form with the button "Register for waiting list": If you have
activated the booking overview, the next page will be the booking overview. In this case, the
button "Add to waiting list now" is used to finally confirm the application. To make it clearer to
the user, we recommend to rename the first button to "Go on to confirmation page", for
example.

The user will receive an automated email that he has applied for the waiting list.

Options in the backend

Email templates for email confirmation to waiting list

You can customize the template for the email confirmation that the user receives when he
applies for the waiting list. At Settings > Tab Default Email Templates, you also find the
template for the waiting list confirmation.
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New application states

Using the waiting list, there are two new application states that are used for this purpose,
waiting list and awaiting response respectively. You can see the applications with such as
waiting list just like other bookings in the backend.

As soon as there are free places, a person on the waiting list can be informed via email
using the backend, or otherwise (e.g. via phone), that there is a free place the user can
apply for. If there is not yet a confirmation from the user, the status of the application can be
set to "avaiting response". This status makes the application count for the computation of
free places.

If the user confirms his application, the status can still be changed manually in the backend:

Changing the states and sending email confirmation with invoice

If the state of an application is changed from waiting list or awaiting response to another
state like submitted, pending or paid, you are asked if you would like to create an invoice
(Prerequisite: The option Options > Create invoices is set to YES).
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If you click "Cancel", no email is sent and no invoice is created. If you click "OK", a email will
always been sent. If the invoice is attached to the email, depends on if the option Options >
Attach to booking confirmation is set.

If the option Options > Create invoices is set to NO, there will never be sent emails if the
status of an application is changed from waiting list or awaiting response to another state like
submitted or pending or paid. If you want to send an email, you have to do this manually
from the backend.

IMPORTANT NOTE: IMPACT OF THE STATUS ON THE FREE PLACES

If an application hat the status „waiting list“, this application does not reduce the number of
free places for a course. An application with the Status „awaiting response“ does count as a
booking in regard to the course places. Counting the free places for a course is done in
relation to the global settings as before.

Special case: Move up from waiting list if there are less places free than needed

If a waiting list application has for example two applicants, but only one place is free, you
may want to set one applicant to be booked to the course and one still on the waiting list.

For this, you have to copy the booking to the same course. The status will automatically be
set to "canceled", the copied one stays on the status. You have to set the canceled
application to status "waiting list" and edit it (e.g. set the number of applicants to "1"). The
copied application also has to be edited accordingly.
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FAQ

Booking forms / custom fields

(Benutzerdefinierte) Felder im Anmeldeformular ändern

Die Felder "Anrede", "Title", "Vorname", "Nachname" und "E-Mail Adresse" sind im Quelltext
fest vorhanden und können nicht ohne weiteres verändert werden. Alle anderen Felder
können im Back-End frei bearbeitet, gelöscht oder neu hinzugefügt werden ("Seminar
Manager > Einstellungen > Tab Einstellungen > Benutzerdefinierte Felder").

Titel und Anrede im Anmeldeformular ausblenden

Achtung: Stand: November 2018 - OSG Seminar Manager Version 2.13.8, die Zeilen
könnten sich in späteren Versionen verschieben

Dazu bitte die Datei
"components/com_seminarman/views/courses/tmpl/default_applicationform.php" bearbeiten
und die entsprechende "<tr>" Elemente entfernen. Am Ende (aber vor "</form>") der Datei
folgendes hinzufügen:

<input type="hidden" name="title" value="" /> bzw.
<input type="hidden" name="salutation" value="" />.

Wenn das Feld "Anrede" ("Salutation") entfernt wurde, zuletzt noch die Datei
"components/com_seminarman/views/courses/tmpl/default.php" bearbeiten und oben in der
JavaScript-Funktion submitbuttonSeminarman die Zeilen von 163 bis 168 löschen.

Darf ich benutzerdefinierte Felder löschen?

Benutzerdefinierte Felder können immer gelöscht werden. Sie sollten folgendes beachten:
Wenn Sie bereits Buchungen haben, sollten Sie freigegebene Felder nicht löschen, da die
damit verbundenen Daten dann nicht mehr zugreifbar sind. Ansonsten kein Problem.

Anmeldebutton funktioniert nicht. Bei Klick auf "Jetzt zahlungspflichtig buchen"
passiert nichts.
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Unserer Erfahrung nach liegt das sehr häufig an einem JavaScript Fehler in Templates.
Testen Sie das am besten mal mit einem Tempalte, dass Joomla! mitliefert. Funktioniert der
Button dann, liegt es an Ihrem Template.

Can I integrate tags for Google Conversion Snippets und Onclick Attributes?

(As of March 2019)

Yes, but at the moment only via override. Use document addScriptDeclaration

Ist es möglich, eine Registrierung im Anmeldeformular zu ermöglichen?

Die beiden Bereiche "remember me" & "registration" sind über CSS versteckt, weil unsere
Komponente optional einen eigenen Registrierungsprozess besitzt. Man kann die beiden
Bereiche wieder aktivieren, indem die folgenden CSS Codes in Custom CSS geschrieben
werden:

div.seminarman div#course_appform form#login-form p#form-login-remember {

display: block;

}

div.seminarman div#course_appform form#login-form ul {

display: block;

}

Can I create multiple booking forms?

No, only one application form can be created that will be displayed on all courses. However,
it is possible to create via override multiple registration forms. Such an override usually costs
us about 1--3 hours of effort, depending on whether it is only a small distinction in the forms
or if, for example, functions should be included, such as the opening of other fields, if a
certain field is clicked on. Later the registration forms created by Override can usually be
extended or changed by yourself. So you would be flexible. If you are interested, then
contact us.
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(Benutzerdefinierte) Felder im Anmeldeformular ändern

Die Felder "Anrede", "Title", "Vorname", "Nachname" und "E-Mail Adresse" sind im Quelltext
fest vorhanden und können nicht ohne weiteres verändert werden. Alle anderen Felder
können im Back-End frei bearbeitet, gelöscht oder neu hinzugefügt werden ("Seminar
Manager > Einstellungen > Tab Einstellungen > Benutzerdefinierte Felder").

Hide title and salutation at the registration form

(As of November 2018 - OSG Seminar Manager Version 2.13.8)
If you are using a later version of the component, please note, that the line numbers could
differ or there could be information missing.

To do this, edit the file "components / com_seminarman / views / courses / tmpl /
default_applicationform.php" and remove the corresponding "<tr>" elements. Add the
following at the end of the file (but before "</form>"):

<Input type = "hidden" name = "title" value = "" /> or

<Input type = "hidden" name = "salutation" value = "" />.

If you have removed the "Salutation" field, then also edit the last file

"Components / com_seminarman / views / courses / tmpl / default.php"

and delete lines from 163 to 168 above in the JavaScript button submitbuttonSeminarman.

Darf ich benutzerdefinierte Felder löschen?

Benutzerdefinierte Felder können immer gelöscht werden. Sie sollten folgendes beachten:
Wenn Sie bereits Buchungen haben, sollten Sie freigegebene Felder nicht löschen, da die
damit verbundenen Daten dann nicht mehr zugreifbar sind. Ansonsten kein Problem.

Anmeldebutton funktioniert nicht. Bei Klick auf "Jetzt zahlungspflichtig buchen"
passiert nichts.

Unserer Erfahrung nach liegt das sehr häufig an einem JavaScript Fehler in Templates.
Testen Sie das am besten mal mit einem Tempalte, dass Joomla! mitliefert. Funktioniert der
Button dann, liegt es an Ihrem Template.

Ist es möglich, eine Registrierung im Anmeldeformular zu ermöglichen?

die beiden Bereiche "remember me" & "registration" sind über CSS versteckt, weil unsere
Komponente optional einen eigenen Registrierungsprozess besitzt. Man kann die beiden
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Bereiche wieder aktivieren, indem die folgenden CSS Codes in Custom CSS geschrieben
werden:

div.seminarman div#course_appform form#login-form p#form-login-remember {

display: block;

}

div.seminarman div#course_appform form#login-form ul {

display: block;

}

Anmeldebutton bei kostenlosen Kursen zeigt "Jetzt zahlungspflichtig buchen"

Es gibt für kostenlose Kurse einen eigenen Sprachparameter, den man nach Belieben
umbennen kann:

COM_SEMINARMAN_CART_FREE_CONFIRM_BUTTON

Dieser greift aber nur, wenn die Buchungsübersicht unter Optionen > Seminar Manager
Einstellungen auf aktiv steht.

Ohne diese Bestell-, bzw. Buchungsübersicht greift der Standardparameter:
"COM_SEMINARMAN_SUBMIT, der bei allen Kurse gleich ist.

Der Grund: Hier kann man nicht garantieren ob dieser Buchungsvorgang kostenlos sein
wird, auch wenn der Kurs kostenlos sein könnte.

Ein Kurs kann multiple Preise besitzen: einer davon kann kostenlos sein, andere nicht. Das
System weiß also beim ersten Laden von dem Kurs nicht welcher Preis gewählt wird.

Auch wenn der Kurs nur einen Preis kostenlos besitzt, weiß das System in diesem Moment
ebenfalls nicht, ob der Benutzer eine zusätzliche Gebühr wählen wird.

Bookings — Attendees

Can I book and rebook an attendee from the backend?

Yes, the plugin "Manual Booking And Invoice" makes it possible.

Can register severeal attendees at the same time?

Yes, it the administrator allows it. This setting you find at Settings>Tab:General>Multiple
Applications per User
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Cours tables

Ist eine standardmäßige Sortierung nach Datum möglich?

Die Sortierung der Kurstabelle stellt man ein unter OSG Seminar Manager -> Einstellungen
-> Optionen -> Reiter: Seminar Manager Einstellungen. Dort gibt es ein Option die
"Reihenfolge" heißt. Hier stellen Sie ein, in welcher Reihenfolge die Seminare in der
Kurstabelle erscheinen.

Unterkategorien werden nicht angezeigt

Es reicht nicht, wenn man nur die obere Kategorie einem Kurs zuordnet. Man muss immer
alle Kategorien zuordnen, in den der Kurs sichtbar sein soll.

Um einen Kurs mehreren Kategorien zuzuordnen, hält man die CTRL-Taste gedrückt und
wählt alle gewünschten Ober- und Unterkategorien in der Auswahlliste aus.

Wie kann ich alle Kurse unter einem Menüpunkt anzeigen?

Um das zu erreichen, muss entweder eine Kategorie oder ein Tag erstellt werden, die/der
dann allen Kursen zugewiesen wird.

Kann ich die freien Plätze in der Kurstabelle anzeigen lassen?

In der Kursdetail-Beschreibung erscheint diese Informationen, in der Kursliste kann man es
nicht anzeigen lassen. Die Information, ob ein Kurs ausgebucht ist, ist jedoch vorhanden. Ist
ein Kurs ausgebucht, ändert sich der Link "jetzt buchen" in "ausgebucht".

Obwohl die Kapazität erreicht ist, der Kurs kann immer noch gebucht werden. Wie
kann ich das abstellen?

Wie die gebuchten Plätze gezählt werden wird hier definiert: Einstellungen -> Optionen >
Aktuelle Kapazität. Bei "Status egal" werden alle Anmeldungen gezählt.... also darauf
umstellen oder den Status der eingegangenen Buchungen ändern.

Kurse bearbeiten, Einstellungen - Edit courses, settings

Kapazität für einen Kurs auf unendlich stellen (unbegrenzte Teilnehmerzahl), geht
das?

Lassen Sie unter Kurs bearbeiten das Feld Kapazität leer, wird dies automatisch als 0
(ausgebucht) gewertet.
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Sie können allerdings unter Optionen > Seminar Manager Einstellungen > "Aktuelle
Kapazität" auf "verbergen" stellen. Dann können alle Kurse ohne Teilnehmerbegrenzung
gebucht werden. Falls das nur für bestimmte Kurse so sein soll, dann finden Sie diese
Option auch unter Kurs beaarbeiten > weitere Parameter.

Kann ich Kurse aus dem Frontend heraus erstellen oder bearbeiten?

Nein, aber Sie können mit den Gruppen Seminar Manager und Seminar Trainer arbeiten.
Der Seminar Trainer hat eingeschränkte Rechte im Backend. Am besten loggen Sie sich als
Seminar Trainer ein und sehen, was möglich ist.

Calendar

The mouseover doesn't appear at the calendar

You probably have an error in your template. Or a plugin that you are using has a conflict
with the calendar.

To check your template, simply activate a template that Joomla provides. If the mouseover
works now, your template has an error. If it works not, then disable other plugins and see if
the problem can be fixed.

If you still use Joomal 2.5, the problem may be another.

Can I display the calendar in a module type "Custom"?

Yes, but in the module of type "Custom" the option "prepare content" should be set to Yes.

Emails and Emailsending

If I want to send an e-mail from the backend, the note appears: SMTP Error: data not
accepted.

In the backend notification, the sender address is the e-mail address of the (admin) user
logged in backend. So, this e-mail address is blocked by the Micrososft Exchange Server as
the sender.

How do I configure the email delivery?

Settings for emails:

1. Seminar Manager -> Options -> Tab: Preferences - Email Recipient

The registered e-mail recipient receives an e-mail in the following cases
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● Information about successful payments via Paypal
● Copy of the e-mail notification to interested parties
● Copy of the e-mail notification to the applicant when booking on list of interested

parties *
● Copy of the e-mail Confirmation to the applicant for course bookings *

* Prerequisite: The field code {ADMIN_CUSTOM_RECIPIENT} is entered in the BCC field or
recipient field of the e-mail templates (Settings - Options - Tab E-Mail Templates).

If the field code {ADMIN_CUSTOM_RECIPIENT} has been overwritten with a valid e-mail
address, an e-mail will be sent to the e-mail address entered there, even if the field remains
empty.

In the frontend appears after the registration "error when sending mail". What does
this mean?

Check the following settings:

1. To each course an e-mail template is assigned. Please check whether the parameter
{EMAIL} is entered in the field "Recipient" in this assigned e-mail template.

2. Check Options -> Preferences -> Email Recipient. There, a valid address should be
entered.

The applicant will not receive a booking confirmation by e-mail.

Ceck the following settings:

1. To each course is assigned an e-mail template. Please check whether the parameter
{EMAIL} is entered in the field "Recipient" in this assigned e-mail template.

2. Another reason might be that Paypal is active and "Invoice After Payment" is set to "Yes"
(under Options -> Payment). In this case, the e-mail will be sent AFTER successful payment.

Import / Export

Wie kann ich große Mengen von Kursen importieren?

Es gibt zur Zeit keine Import-Funktion. Dies müsste direkt auf SQL-Ebene gemacht werden.
phpMyAdmin bietet die Möglichkeit, Daten auch aus CSV-, XML- oder Excel-Dateien zu
importieren.

No bookings will be displayed although they have been received during the period I
enter.
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The period of time that can be set when exporting bookings refers to the beginning of
courses and not the date of receipt of the bookings. At present, it is not possible to filter
according to the date of receipt of the bookings. So, if you choose a period that does not
include a course, no postings will be exported.

General Data Protection Regulation (GDPR)

Does the OSG Seminar Manager create cookies?

No, he does not generate his own cookies. But he produces a so-called "Window Document
Local Storage" because of the memory for the tab state (courses, prospect list, archive).
In some places the OSG Seminar Manager also uses Joomla PHP sessions. This requires a
session cookie, but this is produced by the Joomla system.

Ist the OSG Seminar Manager GDPR compliant?

The OSG Seminar Manager offers you the following options to make your processes
DSGVO compliant:

● You can insert checkboxes for the consent to the processing of personal data
● Logging of creation, modification and deletion of personal data (currently being

developed and will be available with the next update - as of June 2018)

Installation and Update

After the update all headings and labels are shown as php references

It looks like something went wrong with your update installation. We recommend that you
carry out the update installation again.

Please check if there was any error massage after the installation through the extension
manager?

Often such a problem is caused by the missing writing permissions, especially in case of
PHP running as apache module in your webserver.

Usually you can resolve such problems by setting the permissions of the following directories
recursively to 775 (if it doesn’t work, try 777):
- components/
- administrator/components/
- language/
- administrator/language/
- tmp/
Then you can carry out the update installation again. After the successful update you can set
the permissions of the above directories recursively
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Error message when updating: "There was an error uploading this file to the server"

This can happen if the upload limit is too low (for example, only 2 MB). Please check the
upload_max_filesize and post_max_size in php.ini and increase it if necessary.

If you can not change your php.ini, you can also perform the installation manually. To do this,
please simply put the .zip file into the Joomla Temp folder (Joomla / tmp) and install it
manually. You have to do this via FTP, Joomla gives detailed instructions how to "install from
directory" (manually install).

If I try to install, my server always replies with an error message "Error 500".

Error 500 means that the server has a mis-configuration. The following check list can also be
applied if there are general problems with the installation of the OSG Seminar Manager.

Check list:

1. Is PHP used as a CGI-Script or an Apache Module?

2. If PHP is used as a CGI-Script, the following directories (and at best also their
sub-directories) should have the rights 755:

- components/

- administrator/components/

- language/

- administrator/language/

- tmp/

3. If PHP is used as an Apache Module, it has no effect if the directories are "writable" in the
systems information. You either have to activate the Joomla! FTP layer (see configuration ->
server) or set the following directories rights to 775:

- components/

- administrator/components/

- language/

- administrator/language/

- tmp/

4. is the memory_limit in the php.ini too small?

5. is the max_upload_size in the php.ini too small?
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6. is the max_execution_time in the php.ini too small?

7. is Mod_Rewrite in the Apache not activated, but the URL_Rewrite in Joomla is active?

8. is htaccess in the Joomla!-root not available or mis-configured?

9. is the copy() in the php.ini disabled?

How to make an Update/Upgrade from Joomla 2.5 to Joomla 3?

Please follow this order:

1. Backup your Web server

2. Update OSG Seminar Manager for Joomla 2.5 to the latest version

3. Upgrade Joomla! from 2.5 to 3.x

4. Install OSG Seminar Manager for Joomla 3.x

Is it possible to downgrade the component from a higher version to a lower version?

No, it is not possible to automatically downgrade the OSG Seminar Manager to a lower
version.

With appropriate knowledge in databases and Joomla, it is of course possible to perform this
process manually. The following steps would have to be performed (roughly):

- Export of the current database tables of the OSG Seminar Manager

- External storage of already created invoices (pdfs)

- Uninstall the OSG Seminar Manager

- Installation of the lower version

- Adaptations of the database export to the table structure of the required lower version

- Save invoices (PDFs) in the corresponding directory of the now installed OSG Seminar
Manager

If necessary, images stored for tutors or courses or other stored files must also be saved in
advance and copied back later.

How to transfer datas from a joomla installation to a new one (both joomla
installation have the same version)?
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In the following we give only a rough guide. Depending on the settings you have, different
factors have to be considered in practice.

Empty all database tables of the component on the new site (truncate);
If necessary, set the autoincrement value to 0 in MySQL User Table (eg via phpMyAdmin),

otherwise the IDs might not be identical after transmission between both systems.
Now do a DB export / import;

1. Machen Sie vor der Übertragung ein Backup.
2. The OSG Seminar Manager should have the same version on both joomla

installations.
3. If you have been using a user registration on the old site, and logged in users have

made seminar bookings, you should transfer the users and user groups. The transfer
of users between the two systems is not easy, but there are already some
inexpensive softwares that can do that well. Make sure that there is no conflict or
damage with other components (using User Profile)

4. Emty all database tables of the component on the new site (truncate);
5. If necessary, set the autoincrement value to 0 in MySQL User Table (eg via

phpMyAdmin), otherwise the IDs might not be identical after transmission between
both systems

6. Now do the DB Export / Import;
7. You should also transfer images and documents that you use for invoices etc. from

the old site to the new site.

Can I trasfer the datas from Joomla 2.5 to Joomla 3?

Yes, the transfer is possible, this would have to be done manually.

However, the following should be noted:

● Have registered users made a registration?
● Do exist user rules?
● Have tutors been assinged with Joomla User?
● etc.

These associations would be lost if you do not copy the users from J2.5 to J3.5. That means:

● All booking rules (user / category / period / quantity) are removed
● all references between tutors and Joomla users are removed (Tutor can no longer log

into backend);
● created_by and modified_by in courses and course templates are set to an existing

super user (the former information is lost);
● uploaded_by in File Manager is set to an existing super user (the former information

is lost);
● Favorite table is emptied
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You could put it all back if you do not want to copy the users. The result would be that all
courses would basically look like they were created by a Superuser after the data transfer
and the Joomla accounts for the coaches are no longer available and would need to be
recreated.

If you are unsure, you can request a quote from us. If there are no user assignments, we
usually need about 2 hours for the transfer. For user assignments, we need a few hours
more, because we would have to transfer the user or put everything back.

Invoices

PDF Rechnungen oder Teilnehmerlisten werden leer erzeugt.

Häufig ergeben sich Probleme mit den benutzten Joomla! Editoren.

Checkliste:
1. Ist die Default-Rechnungsvorlage gesetzt?
2. Welche Editor Plugin wird benutzt?
Falls TinyMCE:
3. Gehen Sie zu Erweiterungen -> Plugins -> Suche nach Editor -> TinyMCE
4. Check Basisoptionen
5. Ist "<p>-Element" bei "Neue Zeilen" gewählt?
Falls ja, dann gibt es Probleme.
6. Gehen Sie zur PDF Vorlage
7. Checken Sie den HTML Quellcode
8. Existiert ein "<p> </p>" in der Vorlage?
Falls ja, hier das Problem:
Da TinyMCE in Joomla aktiviert ist, wird die PDF-Bibliothek in unserer Komponent die durch
TinyMCE konvertierte HTML benutzen.
In dem obengenannten Punkt 5 wird TinyMCE "<p> </p>" als non-breakable-space-Zeichen
(charcode 160) statt normales Leerzeichen (html code) verstehen, darüberhinaus bricht
unser PDF Generator ab.
PS: passiert es nicht in allen Servern. In manchen Servern wird "charcode 160" bei der
Erstellung der PDFs nicht toleriert.
Lösung: alle "<p> </p>" in der Vorlage löschen, oder durch andere Tags wie "<br />"
ersetzen.

Dies kann auch im Editor eingestellt werden:
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Ändern zu:

Es werden keine Rechnungen erzeugt, obwohl die Option eingeschaltet ist

Wenn der Preis eines Kurses auf 0 steht, werden für diesen Kurse keine Rechnungen
generiert.

Fehlermeldung: TCPDF ERROR: [Image] Unable to get image ...

Wenn Sie in Ihrer Vorlage ein Bild eingebunden haben, können mögliche Gründe für diese
Fehlermeldung sein:

1. ../administrator/com_seminarman/classes/tcpdf/cache hat keine Schreibrechte.
Berechtigung muss auf 755 gesetzt sein.
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2. Einige Server Hosts haben standartmäßig allow_url_fopen und allow_url_include
deaktiviert. TCPDF benötigt diese Funktionen aber, um durch absolute URLs die Bilder
abzurufen.

3. Bei Nutzung des Plugins "Manuelle Buchung und Rechnungerstellung", kann der
Grund sein, dass Sie im Editor bei der Bearbeitung der Rechnungsvorlage ein Bild
eingebunden haben, das eine relative URL verwendet (z.B. images/test.jpg). Damit die PDF
richtig in der "Manuellen Buchung und Rechnungerstellung" erstellt werden kann, muss aber
eine absolute URL verwendet werden (z.B. www.test.de/imanges/test.jpg)! Bitte
vergewisseren Sie sich, dass bei Ihren Editor Einstellungen die absoluten URLs eingestellt
sind. Beim Editor "TinyMCE" finden Sie diese Einstellungen unter
Erweiterungen->plugins->Editor-TinyMCE->URLs

Sobald Sie die Einstellungen geändert haben, bitte einmal den Text in der Vorlage ändern
und speichern, sodass die Datenbank den richtigen Vorlagentext mit den absoluten URLs
abspeichert.

Beim "JCE Editor": JCE Editor -> Edit Global Configuration" ergänzen Sie den folgenden
Parameter in "Advanced: Custom Configuration Variables" um convert_urls:false

Wie kann ich die Rechnungsnummer zurück setzen?

Die Rechnungsnummer können Sie über phpMyadmin zurück setzen. Die Tabelle heißt
#__semianrman_invoice_number.
Voraussetzung ist, dass Sie zuvor alle Rechnungen aus dem Webserver löschen, sowie die
Buchungen aus der Datenbank.

Language and translations

How can I translate custom fields?

Translate it by Joomla > Extensions > Languages > Overrides. The constance is the name of
the custom field.

E.g. COM_STREET

The Translation has to be done in both languages you need..

How can I translate the OSG Seminar Manager extension in my language?

As for all Joomla! extensions the OSG Seminar Manager works with language files for the
backend and frontend functionality. The basic English files can be found in the directory tree
at:

PATH/administrator/language/en-GB/en-GB.com_seminarman.ini

PATH/administrator/language/en-GB/en-GB.com_seminarman.sys.ini
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for the backend and

PATH/language/en-GB/en-GB.com_seminarman.ini

for the frontend.

Here, for all sections, labels and other words, place holders are defined. Depending on your
chosen language, the place holders are replaced by the words or sentences that are found
in the language files of that language. For example, to have a German OSG Seminar
Manager, you will have to create a "de-DE" directory next to the "en-GB" directory. (Always
use the country code of the language you translated to.) Now you copy the English files into
that directory, and rename them by again exchanging the "en-GB" by "de-DE". Now, for all
place holders, put German text instead of the English text into the files.

If you now change the language in Joomla! to German, the OSG Seminar Manager will be
shown in German.

If you translate the OSG Seminar Manager into your own language, we would be happy to
get the language data from you, so that we can give other users the possibility to download
them for their language.

Where can I change the date format for the frontend?

To change the date format, you can override the following language parameter:

COM_SEMINARMAN_DATE_FORMAT2

We recommend to overwrite it via Joomla Extensions -> Languages -> Overrides -> Site.

Instructions can be found here: http://php.net/manual/en/function.date.php The predefined
value of this parameter is "j. M Y" for German and "M j, Y" for English.

How can I, for example, rename the name course into event ?

At Jooma > Extensions > Languages you can rename a lot of names. For this you need to
know the language parameters. These parameters you can find at the language files for site
and admin of the OSG Seminar Manager. The renaming won't get lost if you update the
OSG Seminar Manager

Also see Joomla docs:

https://docs.joomla.org/J3.x:Language_Overrides_in_Joomla:Language

How can I change the date format?
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To change the date format, you must override the language parameter (via Extensions ->
Languages -> Overrides -> Site). A tutorial is available here:
http://php.net/manual/en/function.date.php

The predefined value is "j. M Y" for German and "M j, Y" for English.

How can I translate the TOS Checkbox?

You can translate it like custom fields. But the constant is the checkbox label (in tis case
CUSTOM_TOS_TEXT), not the name of the checkbox.

How can I translate or edit the salutation of the booking form or the trainer?

If you want to have more salutations go to: OSG Seminar Manager > settings > refernce
tables. Put new salutations here.

You can translate it like custom fields. The salutation is written in the xml tables (OSG
Seminar Manager > settings > refernce tables). The constant is the value of the salutation.
e.g. the value is Frau so the constant is Frau

If you want to have NO salutation let the translation empty.

Payment Processes

Is it possible to transfer the invoice number with the transfer to Paypal?

No this self-defined parameter is not allowed with PayPal processing

As far as we know, there is no suitable parameter for individual invoice numbers. May be you
can combine this number with item_name or item_number: ITEM_NAME (your_recycling
number).

For this you should write your own override file for the PayPal Button View:
/views/paypal/tmpl/default.php

In the override file you can use the transaction parameter "invoice".

The invoice number will not be shown on the PayPal Confirmation Page. However, after the
transaction it is listed in the PayPal account details pages at "payment received" at seller
and at "payment sent" at buyer.

Preise, Gebühren, Gutscheine - Prices, fees, coupons

Wie stelle ich eine andere Währung ein?
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In den Optionen des OSG Seminar Managers ("Seminar Manager > Einstellungen >
Optionen") kann im Tab "Vorgabe" die Währung eingestellt werden. Um weitere Währungen
zur Auswahlliste hinzuzufügen, kann die XML-Datei
"administrator/components/com_seminarman/config.xml" bearbeitet werden
(suche nach <option value="USD">USD</option>)

Wie stelle ich die anzeige von Netto auf Brutto um?

Beim Anlegen oder Bearbeiten eines Menüeintrags kann unter "Basisoptionen" die Anzeige
zwischen Netto und Brutto umgeschaltet werden. In E-Mails und Rechnungen gibt es
Variablen mit und ohne Mehrwertsteuer.

wie kann ich die Mehrwertsteuer ausschalten

Unter Kurs bearbeiten muss bei MwSt. 0 angegeben sein. Die Folge: Auf der
Kurs-Detailansicht im Frontend erscheint dann nur der Preis ohne Angabe von zzgl. oder
inkl. MwSt.

In der Menü-Einstellung unter Joomla (Menütyp Kurs-Kategorie) gibt es die Option, den
MwSt. Hinweis in der Kurstabelle zu verbergen.

Kann ich Preise ausblenden, zum Beispiel für kostenlose Kurse?

Für kostenfreie Kurse (Preis 0,00) kann ein selbst definierbarer Freitext gewählt werden
(Optionen->Vorgaben->Preisanzeige). Dieser gilt für die Kurstabelle als auch für das
Buchungsformular.

How to work with coupons?

Eine integrierte Funktion für Gutscheine gibt es nicht.

Hier jedoch ein Tipp, wie man dennoch mit Gutscheinen arbeiten könnte:

Zunächst machen Sie die Bestellung von Gutscheinen auf Ihrer Webseite möglich (mit
eigenem Forumular, oder einer Joomla Komponente).

Auf Ihrem Anmeldeformular für die Seminare ermöglichen Sie die Eingabe der
Gutscheinnummern und/oder des Betrages. Auf der Buchungsübersicht des OSG Seminar
Managers (bei der der Gutscheinbetrag ja nicht abgezogen wird) geben Sie einen Hinweis,
dass auf der Rechnung der Gutscheinbetrag abgezogen wird, soweit die Angaben des
Anmelders richtig sind.

Bei Eingang der Anmeldung überprüfen Sie, ob die Angaben stimmen, die der Anmelder
gemacht hat. Wenn ja, schreiben Sie eine Rechnung für diese Fälle NICHT über den OSG
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Seminar Manager.
Bei den anderen Anmeldungen, die keinen Gutschein angeben, erzeugen Sie nach
Überprüfung der Anmeldung die Rechungen über den OSG Seminar Manager per
Knopfdruck und versenden diese.

Tutors

Fehlermeldung "Access Usergroup Invalid" beim Anlegen eines Trainers
Als erstes überprüfen, ob bereits die Seminar-Trainer- und Seminar-Manager-Gruppen
aktuell/bzw. generiert sind (siehe Screenshot).

Dann bitte noch folgendes beachten:
Auf dem Dropdown werden NICHT alle Joomla Benutzer aufgelistet, dort werden NUR die
Joomla Benutzer, die die folgenden 3 Bedingungen erfüllen, aufgelistet:
1. Kein Admin User / weder SuperAdmin noch Admin; (der Admin User hat bereits Vollzugriff
auf die Komponente)
2. Kein OSG SeminarManager Gruppe User; (der SeminarManager hat bereits Vollzugriff
auf die Komponente)
3. nicht bereits auf einem anderen Trainer verknüpft.

Attendees list

Die Teilnehmerliste zeigt zu hohe Anzahl von Teilnehmern an.

Die Ursache ist, dass es Teilnehmer im Papierkorb gibt, deren Status noch auf bezahlt oder
wird bearbeitet steht. Die werden mitgezählt.

Meine PDF Rechnungen oder Teilnehmerlisten werden leer erzeugt.

Häufig ergeben sich Probleme mit den benutzten Joomla! Editoren.

Checkliste:
1. Ist die Default-Rechnungsvorlage gesetzt?
2. Welche Editor Plugin wird benutzt?
Falls TinyMCE:
3. Gehen Sie zu Erweiterungen -> Plugins -> Suche nach Editor -> TinyMCE
4. Check Basisoptionen
5. Ist "<p>-Element" bei "Neue Zeilen" gewählt?
Falls ja, dann gibt es Probleme.
6. Gehen Sie zur PDF Vorlage
7. Checken Sie den HTML Quellcode
8. Existiert ein "<p> </p>" in der Vorlage?
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Falls ja, hier das Problem:
Da TinyMCE in Joomla aktiviert ist, wird die PDF-Bibliothek in unserer Komponent die durch
TinyMCE konvertierte HTML benutzen.
In dem obengenannten Punkt 5 wird TinyMCE "<p> </p>" als non-breakable-space-Zeichen
(charcode 160) statt normales Leerzeichen (html code) verstehen, darüberhinaus bricht
unser PDF Generator ab.
PS: passiert es nicht in allen Servern. In manchen Servern wird "charcode 160" bei der
Erstellung der PDFs nicht toleriert.
Lösung: alle "<p> </p>" in der Vorlage löschen, oder durch andere Tags wie "<br />"
ersetzen.

Dies kann auch im Editor eingestellt werden:

Ändern zu:
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Tabellenkopf nach Seitenumbruch ist nicht zu sehen.

Die Ursache ist, dass im Quellcode <theader> und <tbody> nicht richtig definiert sind.

Folgendes Beispiel führt zum gewünschten Ergebnis:

<table style="width: 100%;" align="center" border="1">
<thead>
<tr>
<td style="width: 15%;"><span style="color: #000080;"><strong>Nr</strong></span></td>
<td style="width: 15%;"><span style="color:
#000080;"><strong>Firma</strong></span></td>
<td style="width: 15%;"><span style="color:
#000080;"><strong>Name</strong></span></td>
<td style="width: 15%;"><span style="color:
#000080;"><strong>Vorname</strong></span></td>
<td style="width: 15%;"><span style="color:
#000080;"><strong>E-Mail</strong></span></td>
<td style="width: 25%;"><span style="color:
#000080;"><strong>Unterschrift</strong></span></td>
</tr>
</thead>
<tbody>
<tr class="{LOOP}">
<td style="width: 15%;">{LINE_INDEX}</td>
<td style="width: 15%;">{CUSTOM_COMPANY}</td>
<td style="width: 15%;height: .6cm;">{LASTNAME}</td>
<td style="width: 15%;">{FIRSTNAME}</td>
<td style="width: 15%;">{EMAIL}</td>
<td style="width: 25%;"></td>
</tr>
</tbody>
</table>
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